Magisk Bug on Redmi 7a

Magisk Bug on Redmi 7a
5.0 1

Bug description: Magisk wont install on redmi 7a (pine)
Affected version: MK90.0-pine-201910261454-NIGHTLY.zip
Steps to replicate: After install magisk (tried the 20.0 on extension page) on redmi 7a with the last nightly build, the magisk manager say that is not installed.

Try this ADB command :
fastboot root
fastboot disable-verify

Or you can try to flash magisk by packing the boot.img,google it then you know what to do.

i tried this commands in adb but say unknown command.
I already patched, but still saying that is not installed.
btw, thanks :smiley:

Magisk 20 is not even supposed to work except through Recovery section. Check the magisk changelog/issues in GitHub for explanation.

So i can’t use magisk cause this device is 32bit A-only SaR?

кто нибудь получил root?

Has anyone got root?

add TTL fixation to the kernel

You have to root it manually using addon suScreenshot_20191111-055830

not verify , correct code is adb disable-verity ,spelling mistake,sorry.