NX563J Camera doesn't work on latest versions of MK100

Camera app opens but shows black image and then crashes. All apps requiring access to camera crash when they do. This has happened approximately since the mid July releases of MK100. Currently running on MK100.0-nx563j-202005050941-NIGHTLY and still have the same problem.

1 Like

Same problem. Now I’m running MK100.0-nx563j-202007190936-NIGHTLY … Latest without problem.

1 Like

Thanks Francesco, it is a pity I didn’t keep a version of it as I cannot find it to download now. I don’t want to go back to MK90 but I might be forced if this issue is not resolved soon. Too long without camera!! Also, could you check if in that version your video records audio? Latest versions of MK100 I run where I could take pictures, did record video too but there was no audio there.

I flashed the latest MK10 on my NX595 (Z17S) and i have the same problem, no camera is working.
When i start camera2api no camera is shown. Rather front or rear camera.
Hope a solution is found soon.

Thank you

I have opened a thread in the bug section with this problem because here we didn’t receive any solution ;-(

1 Like

Thanks Francesco. I had also opened one before posting here in the International Forum. However no news so far. I did contact recently some developers via PM and they are aware of the issue. But so far there is no estimated date for resolution.

Any news?

Try to clear application data

I have tried with full wipe, with only wipe factory data, with simple upgrade system but nothing is changed. After boot all default fotocamera apps are hidden and the flashlight button is disabled.

Fortunally I have done a full system backup before.

The same problem with 595J. Last working version is MK100.0-nx595j-202007191240-NIGHTLY.zip.
All latest versions cannot use camera or flashlight. Could anybody solve this?