OS unable to boot when I restart

OS unable to boot when I restart
none 0.0 0

OS unable to boot after a restart

Version:
MK100.0-nx611j-220923-RELEASE

Steps:
after flashing ROM,
install gapps (open_gapps-arm64-10.0-pico-20220215.zip)
Login google account,
I install magisk in twrp,
reboot OS with root,
install apps,
use the phone for hours
restart app.
unable to boot.
TWRP unable to wipe data n dalvik

I did this twice an same result, I use phone normally but when I restart, nothing happens.

i have reinstalled OS, disabled dm verity and force encrypt but phone still doesn’t boot up.
only boots when I format data

不好意思,我的中文不强。

try without magisk.

Thanks for the response.
i’ll try that. I noticed that twrp 3.2.3 formats the data patition in f2fs. I manually changed to ext4.
i’ve been able to restart the new installation successfully after loading all my apps and settings but i’m still monitoring the OS.

Just incase I have to uninstall magisk, how else do I root?

also I noticed I’m not getting LTE/4G data network, any reason for that?

thanks again for your time.

The problem comes after I enable fingerprint and PIN. It still doesn’t boot up when I uninstall magisk.
I try to disable dmverity and forceencrypt that makes things even worse as it gets stuck on the nubia logo

I noticed another bug today.
Volume control doesn’t work in-call. whether on speaker or phone.

Edit:The 4G/LTE problem I had earlier was due to my network band not supported

此话题已在最后回复的 30 天后被自动关闭。不再允许新回复。