Return to official rom

Return to official rom
0

#1

Hello

I was using mokee 7.1.1 https://download.mokeedev.com/?device=nx531j so far and I want to go back to stock ROM: https://www.nubia.com/in/support.php?a=download

Boot TWRP (I believe is 3.0), I do wipe of everything except sdext (internal included, I do not care), install zip with official rom and restart … Apparent boots ok but stays on the screen “be yourself” 15 minutes and nothing

I have to do something else?
Thank you


#2

you could try wipe user data and cache again


#3

Just as @kolibre said, i think u need to flash a official rom with official recovery for once again.


#4

need format data first


#5

Wipe user data and cache not working. I try

Official recovery? Can you put some link please? I only found it:https://www.youtube.com/watch?v=cf0YwkvjguM

Format data? Format internal sdcard to fat? Or format data option from TWRP?

And whats about flash boot.img, recovery.img first? https://play.google.com/store/apps/details?id=com.cgollner.flashify&hl=es


#6

Solution: https://forum.xda-developers.com/android/help/return-to-official-rom-t3715698


#7

1.U can unzip recovery from official ROM file that file’s name is end with “.zip” . I’d tried to find recovery in Chinese edition and it was named to “recovery.img” in the root folder of ROM file.

2.After U got the recovery image, u need to flash it to your phone in bootloader or just boot it with command “fastboot boot xxx.img”. ***.img is the name of your recovery file.

3.Choose the language which U can understood :stuck_out_tongue: , Clear user data(This option maybe clear EVERYTHING on UR phone!!! However my phone is.) - Clear Cache - Reboot to Official recovery and clear data and cache again.

4.Then, choose the ROM file and wait for it finish.

NOTICE: My device is NX549J. When I tried back to official ROM I will need for an SD card to store official ROM on it for the Third-part ROM won’t support OTG on official recovery.

GOOD LUCK.


#8

NX531J is discontinued.


#9