Google Maps not working properly on apps

Google Maps not working properly on apps
0

#1

Hello,
I updated my Lenovo Vibe Shot with latest zoom release (2017-12-31).
As known some Play apps are not compatible with it. I tried to install them through APK, but apps using Google Maps (like Strava, Car2Go) are showing blank maps and are not usable.
Is it a general Mokee problem?
Thanks!


#2

Maybe you can give Location permissions to Play Service and Google Maps.
Setting → Location → On
Setting → Apps → Maps(and Play Service) →Permissions → Location


#3

Hello Miuifan,
thanks for answer! Unfortunally permissions are correctly set: Google Maps app itself is working fine (I can use it as GPS navigator). Google Play Services is enabled to any kind of permission, GPS position included.
Any app that uses Gmaps API is not working fine: i.e. Car2Go app below, but also Gobee bike, Obike, … They show a grey empty space with Google logo.
Wondering if it’s a common problem.
Thanks

![97112293-d844-4951-b006-ac56d75fcb51|281x500]
(upload://dpepG0M27kXqP0kdl5H7Q9XsYfb.jpg)

image


#4

so regrettable, It’s normal for my device to use Google maps and Car2Go.
Your Car2Go has no Location permission? Or is it just the problem of this device?


#5

Thanks again for testing this issue!
Are you testing on a Lenovo Vibe Shot/Zoom?
Permissions on Car2Go seem to be correctly set. I was using these apps on Marshmallow, maps were showed correctly. I send screenshots about my config below:

image


#6

I’m so sorry I don’t have zoom.:grinning:


#7

How did you installed your GoogleApps? Maybe your maps dont have enough access.First uninstallall your GoogleApps,then try to download the GoogleApps package from OPENGAPPS website,lastly install it via recovery.I used to fix my Googlemap problem in this way,hope to help you.


#8

Hello,
Thanks for your help! I firstly installed from Gapps (arm64 7.1 stock), with TWRP.
Now i tried to install them again after your hint, then I wiped cache and delvik.
Infortunatelly maps are still not working! How did u uninstall Gapps?
Thanks!


#9

Errrrrrrrr
The easiest way is to delete their folders with RootExplore.
Here’s the path


#10

After deleteing, remember to reboot your phone.:smiley: