Nightly error

Please can someone help I have donated to this Rom so I can get incremental updated but when I try to install incremental update I get error

version mismatch. please check if you have downloaded a correct package.

Package is correct thanks