关于安装有Google服务包的机油在增量更新到2018-08-12每夜版时失败的解决方案

关于安装有Google服务包的机油在增量更新到2018-08-12每夜版时失败的解决方案
0

#1

自从MK81.0支持增量更新以来,老猪我每天都在使用增量更新的方式更新手机系统。
除了它确实便捷、好用,更是为了时刻跟踪,不断完善它,因为世界上没有任何东西是完美的。
在稳定使用半个月之后,老猪我在增量更新今天的每夜版时终于失败了,想必也有不少机油遇到了。

失败原因说明:
使用增量更新升级系统时,手机重启到REC后停留在主界面,没有进行更新。


点击右下角菜单键调出刷机日志后,发现错误代码为7,错误原因为ExtShared.apk文件遭到篡改。

老猪我检查谷歌服务包,发现8.1版本会对该文件进行替换。
而魔趣的增量更新尚未将其列入排除列表,导致更新时出现冲突。

解决方案与答疑:
1.没有装Google服务包的机油完全不受此问题影响,可以正常使用增量更新。
2.安装有Google服务包的机油只需跳过12号的增量更新,等13号的发布后,直接更新到13号版本即可。

写在最后:
魔趣的增量更新是我们引以为傲的杰作,它是目前市面上最强、兼容性最好的增量更新方案。
我们欢迎更多的机油尝试它,在享受快速更新的同时,帮助我们使它变得更完美。

扩展阅读:


#2

感谢,刚把OTA包下载完,随手点开论坛,就看到了这个,那就不升了,等明天再升吧,谢谢提醒


#3

mix2s,还有一个bookmarkprovider也没了


#4

能给个截图吗?微博私信我


#5

谢谢马丁大大~我今天再试试看


#6


13号的也有


#7

mix2s,11号到12号的错误如六楼所示,貌似还没解决。我将11号完整包里的BookmarkProvider.apk和ExtShared.apk放了回去,成功刷入了12号的增量,又另外发现了新问题:今天准备刷13号,进入rec发现没有让我输pin码,而sdcard被加密,不知如何解密。


#8

同样13号的包提示bookmarkprovider错误


更新到MK81.0-polaris-201808121027-NIGHTLY后recovery无法解密sdcard
#9

已发现,明天修复。。这是个漏网之鱼。。


#10

没刷谷歌包也是错误7。破2


#11


建议你看清楚这个


#12

报告龙大,14日的更新包还是不能刷入,BuiltInPrintService.apk 需要添加例外(到底还有多少漏网之鱼啊……


#13

full包本来就不是我们推荐的版本,我们的指引里说过支持pico, nano, stock。 麻烦认真看一下。这个我们不会加入到排除列表里去的


刷open gapps完整包刷不了(红米Note5 Pro)
#14

龙大你好,指引我是看过的。不过这里我想指出 stock 版和 full 版几乎是一样的,而且 full 版还不会像 stock 版一样替换系统原本就有的应用(见下图)

并且从 GitHub 的 Wiki 页 来看,full 版安装的 Gapps 比 stock 版还要少一些

这样来看的话龙大是否可以把我在 12 楼反映的 APP 也加入排除列表里面呢?
因为如果魔趣的增量升级包可以支持 stock 版的 Gapps 包,那毫无疑问也应该支持 full 版的 Gapps 包不是吗?


#15

龙大好,魔趣81 从 28 号开始到今天的增量更新包都无法刷入了。报错误 7。
详细信息如图所示,是 Exchange2.apk 包的问题,希望能添加到排除名单里。
我今年暑假结束后没多久重新刷机了一次,这一次我刷的 gapps 包就是 stock 版了。
应该不会像上次那样告诉我说不会支持吧?:unamused:
麻烦您了,提前谢过了~
// 我也很想早点刷上喷香的新版本魔趣中心啊 :sweat_smile:


香喷喷的全新魔趣中心将在MK81.0 2018年11月29日每夜版生效,有奖征集新程序图标!