mokee oreo 8.1

thanks you very much miuifan,

I use magisk 17.1 and tried beta 17.2 yesterday night and only rootapps are hiden. (afwall+ busybox pro, adaway and rootchecker and amaze file root explorer)
but i see in your images is play store hidden.
do i have to hide any more google or other apps available in systemsettings/applications ?

What?Can’t they use Root permissions? Sorry I don’t quite understand this sentence.

Maybe you have mistaken the app, this app is Google Pay, not the Google Play Store. :rofl:
Google Pay is available for NFC payments, But if it detects that the BootLoader has been unlocked, it will no longer be available, so I opened this option.
I don’t think you need to hide Magisk for system apps and other Google apps. :sweat_smile:

image

hello miuifan,

sorry about mistaken the app (i read your ansewer in my car with my 5" smartphone)
so i have to hide google pay and if i dont use google pay i do not have to hide any other apps, isn’t it?
…but i dont understand… because i think that the other google apps are that kind of clever to give this information to google pay

i still have no green cts-profile in safety-net-status

does the mokee pay app needs to have a magisk hide hook too?
maybe this is my speed problem because mekee center says that i havn’t payd anything…
or is a donation good only for some month?

moreover i use mokee rom nightly from 10.10.2018, red wolf twrp, and magisk 17.1
and fingerprint is still not working in my new rom, what the reason is for my dayly rom-update

thank you

MoKee’s donation record is permanent. After obtaining a donation authorization, MoKee will generate an authorization file in /sdcard, Its name is mokee.license. At the same time, MoKee will synchronize the authorization file to the cloud server.

If you just deleted the authorization file by mistake, you can manually restore it. The steps are:
MoKee Center -> image in the upper right corner -> Click “Restore license” option.

The authorization file is generated based on the device ID, The device ID is generated according to the serial number through a special algorithm. So the authorization for each device is unique.

Of course, there are multiple device ID for dual card devices. By default, MoKee reads the serial number of SIM card 1 as the device ID.
In general, the device serial number is the IMEI, but the CDMA device is the MEID. So this may cause a situation that MoKee can’t control, that is, the device ID may change as the user replaces the SIM card of different operators.

If you fail the license due to card replacement, you can put the original SIM card 1 back to the current SIM card 1 slot.
If you no longer use the old SIM card, or if you need to exchange the SIM card 1 and SIM card 2 locations, you can contact Leader @martincz to migrate your license, this can solve your problem.

I think this may be caused by incorrect system bottom package.
Flashing third-party ROMs often only installs the system, vendor and the boot. And our phone contains more than twenty other partitions that we can’t view, they are provided by the system bottom of original factory, and guarantee the normal operation of the phone.
For example, if the driver in the system is updated and TrustZone is not updated, the fingerprint sensor may not be normal. If the Modem version is incorrect, it may result in no network…

You can try flashing other versions of ZUI (Such as the latest version), then flash back to MoKee to see if the problem is still there. No need to clear data, and don’t start phone halfway.

very good support but i miss the restore licence olption in my menu and really, i chanded both sim cardes the last time because network problems and now rechanged it, but still no licence option in my menu and moreover i have got a new sim in the meantime because my provider gave a new one because he said “maybe broken”
and i do not have the old one any more. but its easyer to redonate :slight_smile:

where to download a new zui because i deleted mine because no german language (just english and chinese)

Maybe you don’t need to flash ZUI, I have found some bottom package for z2pro. They are extracted from ZUI 2.3 (Android M), 2.5 (Android N), 3.1 (Android N), and 3.5 (Android O).
I found it here: https://club.lenovo.com.cn/thread-4281883-1-1.html

Considering the trouble of using Chinese cloud disk, I uploaded them to MEGA, this is the link: https://mega.nz/#F!BAg1mQRZ!OeY2GodRgIg69tnk8Z0aZQ

???

left side on my Phone and in the menu is no licence option

thanks for your mega upload but what to do with these files? in my case for oreo would match the last one i think, isnt it? but what to do.

is there a way to reset the security settings in the same way like by network settings?

How to update the bottom package, you can read this article:


I think this is a display bug, maybe you should change the display size:

Settings -> Display -> Dosplay size -> Choose a smaller size

The option is here:

please forget my entry from before or delet it

hurray, my licence is back again - display and font were to big so it was hidden…
thank you, miuifan

…but if i do the steps provided about the bottom package… i get an error 7 in RED WOLF TWRP
i was using ZUI3.5_RADIO_O8.0_from_ZUI_3.5.217.zip because i think its for oreo
i even tried after backing up… i wiped dalvik cache and system and not my internal storage but the same so i think its not the .

but if i make reinstall after wiping system cache and dalvik AND DATA the fingerprint option is working, so i just believe that there is something to delete or reset in the data folder…

i just reinstalled daily rom and recoverd all apps and settings with google cloud but each settings in most apps are set up to standard way i totally dont like it despite i made a backup. so this app google recovery is not working…
i saved and wiped it and use my old data partition with broken fingerprint-funktion because get crazy about annoying animations, formatings keysound all the time.

any idea how to reset fingerprint in the data folder?
is ther a way to save all installed apps and all settings of this installed apps in a easy way to my internal storage?

hahahahahhhh…

Then I guess this is not a problem with the bottom package. maybe the z2pro maintainer did not update the bottom package. After all, I don’t have this phone, so I don’t know very well.
This may be because you did not wipe the data when updating from MK71 to MK81, and the old data is not compatible with new systems. so your fingerprints won’t work in the past.

haha,I don’t know if TWRP is too old or because there is a problem with the bottom package.
But what is the specific error, it depends on the prompt text in front of “error7”.
The next time you encounter error 7, you can read it yourself, or you can take a screenshot and send it here.
press the power button and volume down button at the same time to get a screenshot on TWRP Recovery.

it’s not about the bottom packaqge (while installing error 7 something with updater script…)

there muß be something to delete?
i have deleted an emty folder yesterday fdpata (i think it was /data/users/0/…
ther was nothing inside.
always i trie to open the fingerprint setting i get (settings is chrashed restart or leave closed)
…and in magisk settings the both last fingerprint options are ghoosted

which app kann be reinstalled to reset this (i red about fingertouch…)
or is there a setting inside google apps (i red about locksreen…)

i remember a looong time ago after an update i had to delete some files about passwort database because i and many others too were not able to login because get wrong password message.

there is noch way to reset the fingerprint option app …

I wish a happy chinese weekend to you and preciate your helpful forum…:grin:

:joy: i don’t know,
I think that z2pro users reading your article may be more helpful to your problem.

hello miuifan , my good supporter
:slight_smile:

what are the rules in this forum? can i add another question inside of this chat or do i have to start a new one?
my question would be about trust and SELinux…
I get the trust notice at systemstart that SELinux is NOT strict - and maybe this is the reason for my not accepted CTS-Profile missmatch.

Do you think it shall be strict? so how can i make my selinux strict (or hide it, because its not)
I remember your screenshot at the beginning with crsprofile and basicintegrity (both are true)

mopreover i tried to use incremental updates but i cant install them error 7 (updater process)
I use RED wolf TWRP (passwort protected)

This is very casual, depending on yourself.

I think the SELinux status depends on how much the device maintainer can develop.
MoKee does not have this mandatory requirement for SElinux status compared to LineageOS, Some devices’ MoKee, its SELinux status is not enforcing, such as your Z2Pro. This may be one of the reasons why z2Pro is supported by MoKee.
If you feel that the boot reminder is very headache, you can turn this notification off. The method is to turn off the bottom two options of the Trust setting.

Yes. But I don’t know much about the relationship between SELinux and them.

RED wolf TWRP? Maybe you can try official TWRP Recovery or others Recovery.

thank you very much
i turned of these two bottom options
but stay with red wolf because password protection.

OK :smiley:

another thing

is there an android app or another way available to sync my own contacts bidirectional from my own postgres database into the android contactdatabase/phonebook like google does it?

…and is there a way to disable this annoying privacy notification from android system?

Is there a screenshot? I don’t know what this app is.

i am talking about the right icon at the left side in the statuspanel.

important for me too:
is there an android app or another way available to sync my own contacts bidirectional from my own postgres database into the android contactdatabase/phonebook like google does it?

best regards

after last update zukz2 does not charge anymore.
is there a stable release available?